MySQL 5.6.x < 5.6.39 Multiple Vulnerabilities (January 2018 CPU)

Medium Nessus Plugin ID 106099

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MySQL running on the remote host is 5.6.x prior to 5.6.39. It is, therefore, affected by multiple vulnerabilities as noted in the January 2018 Critical Patch Update advisory. Please consult the CVRF details for the applicable CVEs for additional information.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to MySQL version 5.6.39 or later.

See Also

https://dev.mysql.com/doc/relnotes/mysql/5.6/en/news-5-6-39.html

http://www.nessus.org/u?ae82f1b1

http://www.nessus.org/u?3c1c0186

Plugin Details

Severity: Medium

ID: 106099

File Name: mysql_5_6_39.nasl

Version: 1.7

Type: remote

Family: Databases

Published: 2018/01/17

Modified: 2018/07/17

Dependencies: 10719, 91823

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:mysql

Required KB Items: Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2018/01/16

Vulnerability Publication Date: 2018/01/16

Reference Information

CVE: CVE-2017-3737, CVE-2018-2562, CVE-2018-2573, CVE-2018-2583, CVE-2018-2590, CVE-2018-2591, CVE-2018-2612, CVE-2018-2622, CVE-2018-2640, CVE-2018-2645, CVE-2018-2647, CVE-2018-2665, CVE-2018-2668, CVE-2018-2696, CVE-2018-2703

BID: 102103, 102495, 102678, 102681, 102682, 102697, 102698, 102701, 102704, 102706, 102708, 102710, 102711, 102713, 102714