openSUSE Security Update : postgresql94 (openSUSE-2018-38)

High Nessus Plugin ID 106067

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for postgresql94 fixes the following issues :

Security issues fixed :

- CVE-2017-15098: Fix crash due to rowtype mismatch in json{b}_populate_recordset() (bsc#1067844).

- CVE-2017-12172: Start scripts permit database administrator to modify root-owned files. This issue did not affect SUSE (bsc#1062538).

Bug fixes :

- Update to version 9.4.15

- https://www.postgresql.org/docs/9.4/static/release-9-4-15.html

- https://www.postgresql.org/docs/9.4/static/release-9-4-14.html

This update was imported from the SUSE:SLE-12:Update update project.

Solution

Update the affected postgresql94 packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1062538

https://bugzilla.opensuse.org/show_bug.cgi?id=1067844

https://www.postgresql.org/docs/9.4/release-9-4-14.html

https://www.postgresql.org/docs/9.4/release-9-4-15.html

Plugin Details

Severity: High

ID: 106067

File Name: openSUSE-2018-38.nasl

Version: 3.6

Type: local

Agent: unix

Published: 2018/01/16

Updated: 2018/12/18

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.2

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

CVSS v3.0

Base Score: 8.1

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:postgresql94, p-cpe:/a:novell:opensuse:postgresql94-contrib, p-cpe:/a:novell:opensuse:postgresql94-contrib-debuginfo, p-cpe:/a:novell:opensuse:postgresql94-debuginfo, p-cpe:/a:novell:opensuse:postgresql94-debugsource, p-cpe:/a:novell:opensuse:postgresql94-devel, p-cpe:/a:novell:opensuse:postgresql94-devel-debuginfo, p-cpe:/a:novell:opensuse:postgresql94-libs-debugsource, p-cpe:/a:novell:opensuse:postgresql94-plperl, p-cpe:/a:novell:opensuse:postgresql94-plperl-debuginfo, p-cpe:/a:novell:opensuse:postgresql94-plpython, p-cpe:/a:novell:opensuse:postgresql94-plpython-debuginfo, p-cpe:/a:novell:opensuse:postgresql94-pltcl, p-cpe:/a:novell:opensuse:postgresql94-pltcl-debuginfo, p-cpe:/a:novell:opensuse:postgresql94-server, p-cpe:/a:novell:opensuse:postgresql94-server-debuginfo, p-cpe:/a:novell:opensuse:postgresql94-test, cpe:/o:novell:opensuse:42.2, cpe:/o:novell:opensuse:42.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2018/01/15

Reference Information

CVE: CVE-2017-12172, CVE-2017-15098