Apple TV < 11.2 Multiple Vulnerabilities

High Nessus Plugin ID 105612

Synopsis

The remote Apple TV device is affected by multiple vulnerabilities.

Description

According to its banner, the version of Apple TV on the remote device is prior to 11.2. It is, therefore, affected by multiple vulnerabilities as described in the HT208327 security advisory.

Note that only 4th and 5th generation models are affected by these vulnerabilities.

Solution

Upgrade to Apple TV version 11.2 or later. Note that this update is only available for 4th and 5th generation models.

See Also

https://support.apple.com/en-us/HT208327

http://www.nessus.org/u?262ee1b8

Plugin Details

Severity: High

ID: 105612

File Name: appletv_11_2.nasl

Version: 1.9

Type: remote

Family: Misc.

Published: 2018/01/05

Updated: 2019/06/04

Dependencies: 93741

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2017-7162

CVSS v2.0

Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 7.8

Temporal Score: 7.2

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apple:apple_tv

Required KB Items: AppleTV/Version, AppleTV/Model, AppleTV/URL, AppleTV/Port

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/12/04

Vulnerability Publication Date: 2017/12/04

Exploitable With

Metasploit (Safari Webkit Proxy Object Type Confusion)

Reference Information

CVE: CVE-2017-7154, CVE-2017-7156, CVE-2017-7157, CVE-2017-7160, CVE-2017-7162, CVE-2017-13833, CVE-2017-13855, CVE-2017-13856, CVE-2017-13861, CVE-2017-13862, CVE-2017-13865, CVE-2017-13866, CVE-2017-13867, CVE-2017-13868, CVE-2017-13869, CVE-2017-13870, CVE-2017-13876

APPLE-SA: APPLE-SA-2017-12-6-4