Gallery Bank Plugin for WordPress < 2.0.20 XSS

Medium Nessus Plugin ID 105258

Synopsis

The remote web server is affected by multiple reflected cross-site scripting vulnerabilities.

Description

According to its self-reported version, the Gallery Bank Plugin for WordPress running on the remote web server is prior to 2.0.20.
It is, therefore, affected by multiple reflected cross-site scripting vulnerabilities.

A remote attacker can exploit these issues, via a specially crafted request, to execute arbitrary code in a user's browser, within the security context of the affected site.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the Gallery Bank Plugin for WordPress to version 2.0.20 or later.

See Also

https://wordpress.org/plugins/gallery-bank

https://wpvulndb.com/vulnerabilities/6985

https://wpvulndb.com/vulnerabilities/6986

https://wpvulndb.com/vulnerabilities/6987

Plugin Details

Severity: Medium

ID: 105258

File Name: wordpress_gallery_bank_2020.nasl

Version: $Revision: 1.2 $

Type: remote

Published: 2017/12/15

Modified: 2017/12/18

Dependencies: 18297

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4

Temporal Score: 3.3

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

CVSSv3

Base Score: 2.4

Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:N

Vulnerability Information

CPE: cpe:/a:wordpress:wordpress

Required KB Items: installed_sw/WordPress, www/PHP

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/09/02

Vulnerability Publication Date: 2014/08/01