MariaDB 10.3.1 < 10.3.2 Multiple DoS Vulnerabilities

Medium Nessus Plugin ID 105079

Synopsis

The remote database server is affected by multiple denial of service vulnerabilities.

Description

The version of MariaDB running on the remote host is prior to 10.3.2. It is, therefore, affected by multiple denial of service vulnerabilities.

Solution

Upgrade to MariaDB version 10.3.2 or later.

See Also

https://mariadb.com/kb/en/mariadb/mariadb-1032-changelog/

Plugin Details

Severity: Medium

ID: 105079

File Name: mariadb_10_3_2.nasl

Version: 1.5

Type: remote

Family: Databases

Published: 2017/12/07

Modified: 2018/08/08

Dependencies: 10719, 91823

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 4.3

Temporal Score: 3.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mariadb:mariadb

Patch Publication Date: 2017/10/09

Vulnerability Publication Date: 2017/10/09