MariaDB 10.0.x < 10.0.33 / 10.1.x < 10.1.27 Multiple Vulnerabilities

Medium Nessus Plugin ID 105076

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MariaDB running on the remote host is prior to 10.0.x prior to 10.0.33 or 10.1.x prior to 10.1.27. It is, therefore, affected by multiple vulnerabilities.

Solution

Upgrade to MariaDB version 10.0.33 / 10.1.27 or later.

See Also

https://mariadb.com/kb/en/mariadb/mariadb-10033-changelog/

https://mariadb.com/kb/en/mariadb/mariadb-10127-changelog/

https://mariadb.com/kb/en/library/security/

Plugin Details

Severity: Medium

ID: 105076

File Name: mariadb_10_1_27.nasl

Version: 1.5

Type: remote

Family: Databases

Published: 2017/12/07

Modified: 2018/07/16

Dependencies: 10719, 91823

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4

Temporal Score: 3

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 7.7

Temporal Score: 6.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mariadb:mariadb

Required KB Items: Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/09/25

Vulnerability Publication Date: 2017/09/25

Reference Information

CVE: CVE-2017-3308, CVE-2017-3309, CVE-2017-3453, CVE-2017-3456, CVE-2017-3464, CVE-2017-3636, CVE-2017-3641, CVE-2017-3653, CVE-2017-10286, CVE-2017-10379, CVE-2017-10384

BID: 97725, 97742, 97776, 97818, 97831, 99736, 99767, 99810, 101397, 101415, 101406