openSUSE Security Update : ansible (openSUSE-2017-1259)

High Nessus Plugin ID 104522

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for ansible to version 2.4.1.0 fixes the following vulnerabilities :

- CVE-2017-7481: Security issue with lookup return not tainting the jinja2 environment (bsc#1038785)

- CVE-2016-9587: host to controller command execution vulnerability (bsc#1019021)

- CVE-2016-8628: Command injection by compromised server via fact variables (bsc#1008037)

- CVE-2016-8614: Improper verification of key fingerprints in apt_key module (bsc#1008038)

- CVE-2017-7550: jenkins_plugin module may have exposed passwords in remote host logs (bsc#1065872)

This update also contains a number of upstream bug fixes and improvements.

Solution

Update the affected ansible package.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1008037

https://bugzilla.opensuse.org/show_bug.cgi?id=1008038

https://bugzilla.opensuse.org/show_bug.cgi?id=1019021

https://bugzilla.opensuse.org/show_bug.cgi?id=1038785

https://bugzilla.opensuse.org/show_bug.cgi?id=1065872

Plugin Details

Severity: High

ID: 104522

File Name: openSUSE-2017-1259.nasl

Version: 3.5

Type: local

Agent: unix

Published: 2017/11/13

Updated: 2019/04/10

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:ansible, cpe:/o:novell:opensuse:42.2, cpe:/o:novell:opensuse:42.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/11/10

Reference Information

CVE: CVE-2016-8614, CVE-2016-8628, CVE-2016-9587, CVE-2017-7481, CVE-2017-7550