Debian DLA-1168-1 : graphicsmagick security update

Medium Nessus Plugin ID 104501

Synopsis

The remote Debian host is missing a security update.

Description

A remote denial of service vulnerability has been discovered in graphicsmagick, a collection of image processing tools and associated libraries.

A specially crafted file can be used to produce a heap-based buffer overflow and application crash by exploiting a defect in the AcquireCacheNexus function in magick/pixel_cache.c.

For Debian 7 'Wheezy', these problems have been fixed in version 1.3.16-1.1+deb7u14.

We recommend that you upgrade your graphicsmagick packages.

Note: The previous graphicsmagick package inadvertently introduced a dependency on liblcms2-2. This version of the package returns to using liblcms1. If your system does not otherwise require liblcms2-2, you may want to consider removing it following the graphicsmagick upgrade.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2017/11/msg00013.html

https://packages.debian.org/source/wheezy/graphicsmagick

Plugin Details

Severity: Medium

ID: 104501

File Name: debian_DLA-1168.nasl

Version: 3.5

Type: local

Agent: unix

Published: 2017/11/13

Updated: 2018/07/09

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:graphicsmagick, p-cpe:/a:debian:debian_linux:graphicsmagick-dbg, p-cpe:/a:debian:debian_linux:graphicsmagick-imagemagick-compat, p-cpe:/a:debian:debian_linux:graphicsmagick-libmagick-dev-compat, p-cpe:/a:debian:debian_linux:libgraphics-magick-perl, p-cpe:/a:debian:debian_linux:libgraphicsmagick++1-dev, p-cpe:/a:debian:debian_linux:libgraphicsmagick++3, p-cpe:/a:debian:debian_linux:libgraphicsmagick1-dev, p-cpe:/a:debian:debian_linux:libgraphicsmagick3, cpe:/o:debian:debian_linux:7.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/11/10

Reference Information

CVE: CVE-2017-16669