MariaDB 10.0.x < 10.0.31 / 10.1.x < 10.1.23 / 10.2.x < 10.2.7 Multiple Vulnerabilities

High Nessus Plugin ID 104437

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MariaDB running on the remote host is prior to 10.0.x prior to 10.0.31, 10.1.x prior to 10.1.23, or 10.2.x prior to 10.2.7. It is, therefore, affected by multiple vulnerabilities.

Solution

Upgrade to MariaDB version 10.0.31 / 10.1.23 / 10.2.7 or later.

See Also

https://mariadb.com/kb/en/mariadb/mariadb-10031-changelog/

https://mariadb.com/kb/en/mariadb/mariadb-10123-changelog/

https://mariadb.com/kb/en/mariadb/mariadb-1027-changelog/

Plugin Details

Severity: High

ID: 104437

File Name: mariadb_10_0_31.nasl

Version: 1.3

Type: remote

Family: Databases

Published: 2017/11/07

Modified: 2018/05/17

Dependencies: 10719, 91823

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.8

Temporal Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

CVSSv3

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: cpe:/a:mariadb:mariadb

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/05/23

Vulnerability Publication Date: 2016/12/06

Reference Information

CVE: CVE-2017-3308, CVE-2017-3309, CVE-2017-3453, CVE-2017-3456, CVE-2017-3464

BID: 97725, 97742, 97776, 97831, 97818