MariaDB 10.0.x < 10.0.31 / 10.1.x < 10.1.23 / 10.2.x < 10.2.7 Multiple Vulnerabilities

medium Nessus Plugin ID 104437
New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it is different from CVSS.

VPR Score: 4.4


The remote database server is affected by multiple vulnerabilities.


The version of MariaDB running on the remote host is prior to 10.0.x prior to 10.0.31, 10.1.x prior to 10.1.23, or 10.2.x prior to 10.2.7. It is, therefore, affected by multiple vulnerabilities.


Upgrade to MariaDB version 10.0.31 / 10.1.23 / 10.2.7 or later.

See Also

Plugin Details

Severity: Medium

ID: 104437

File Name: mariadb_10_0_31.nasl

Version: 1.7

Type: remote

Family: Databases

Published: 11/7/2017

Updated: 11/12/2019

Dependencies: 10719, 91823

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

VPR Score: 4.4

CVSS Score Source: CVE-2017-3464

CVSS v2.0

Base Score: 4

Temporal Score: 3

Vector: AV:N/AC:L/Au:S/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 4.3

Temporal Score: 3.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mariadb:mariadb

Required KB Items: Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 5/23/2017

Vulnerability Publication Date: 12/6/2016

Reference Information

CVE: CVE-2017-3308, CVE-2017-3309, CVE-2017-3453, CVE-2017-3456, CVE-2017-3464

BID: 97725, 97742, 97776, 97818, 97831