Debian DSA-4013-1 : openjpeg2 - security update

Medium Nessus Plugin ID 104339

Synopsis

The remote Debian host is missing a security-related update.

Description

Multiple vulnerabilities in OpenJPEG, a JPEG 2000 image compression / decompression library, may result in denial of service or the execution of arbitrary code if a malformed JPEG 2000 file is processed.

Solution

Upgrade the openjpeg2 packages.

For the oldstable distribution (jessie), these problems have been fixed in version 2.1.0-2+deb8u3.

For the stable distribution (stretch), these problems have been fixed in version 2.1.2-1.1+deb9u2.

See Also

https://packages.debian.org/source/jessie/openjpeg2

https://packages.debian.org/source/stretch/openjpeg2

https://www.debian.org/security/2017/dsa-4013

Plugin Details

Severity: Medium

ID: 104339

File Name: debian_DSA-4013.nasl

Version: 3.3

Type: local

Agent: unix

Published: 2017/11/02

Updated: 2019/04/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:openjpeg2, cpe:/o:debian:debian_linux:8.0, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/10/31

Reference Information

CVE: CVE-2016-10504, CVE-2016-1628, CVE-2016-5152, CVE-2016-5157, CVE-2016-9118, CVE-2017-14039, CVE-2017-14040, CVE-2017-14041, CVE-2017-14151, CVE-2017-14152

DSA: 4013