SUSE SLED12 / SLES12 Security Update : curl (SUSE-SU-2017:2831-1)

Medium Nessus Plugin ID 104117

Synopsis

The remote SUSE host is missing one or more security updates.

Description

This update for curl fixes the following issues: Security issues fixed :

- CVE-2017-1000254: FTP PWD response parser out of bounds read (bsc#1061876)

- CVE-2017-1000257: IMAP FETCH response out of bounds read (bsc#1063824) Bugs fixed :

- Fixed error 'error:1408F10B:SSL routines' when connecting to ftps via proxy (bsc#1060653)

Note that Tenable Network Security has extracted the preceding description block directly from the SUSE security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product :

SUSE Linux Enterprise Software Development Kit 12-SP3:zypper in -t patch SUSE-SLE-SDK-12-SP3-2017-1758=1

SUSE Linux Enterprise Software Development Kit 12-SP2:zypper in -t patch SUSE-SLE-SDK-12-SP2-2017-1758=1

SUSE Linux Enterprise Server for Raspberry Pi 12-SP2:zypper in -t patch SUSE-SLE-RPI-12-SP2-2017-1758=1

SUSE Linux Enterprise Server 12-SP3:zypper in -t patch SUSE-SLE-SERVER-12-SP3-2017-1758=1

SUSE Linux Enterprise Server 12-SP2:zypper in -t patch SUSE-SLE-SERVER-12-SP2-2017-1758=1

SUSE Linux Enterprise Desktop 12-SP3:zypper in -t patch SUSE-SLE-DESKTOP-12-SP3-2017-1758=1

SUSE Linux Enterprise Desktop 12-SP2:zypper in -t patch SUSE-SLE-DESKTOP-12-SP2-2017-1758=1

SUSE Container as a Service Platform ALL:zypper in -t patch SUSE-CAASP-ALL-2017-1758=1

OpenStack Cloud Magnum Orchestration 7:zypper in -t patch SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2017-1758=1

To bring your system up-to-date, use 'zypper patch'.

See Also

https://bugzilla.suse.com/show_bug.cgi?id=1060653

https://bugzilla.suse.com/show_bug.cgi?id=1061876

https://bugzilla.suse.com/show_bug.cgi?id=1063824

https://www.suse.com/security/cve/CVE-2017-1000254/

https://www.suse.com/security/cve/CVE-2017-1000257/

http://www.nessus.org/u?ab1d52b2

Plugin Details

Severity: Medium

ID: 104117

File Name: suse_SU-2017-2831-1.nasl

Version: 3.9

Type: local

Agent: unix

Published: 2017/10/24

Updated: 2019/09/11

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.4

Temporal Score: 4.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.1

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:curl, p-cpe:/a:novell:suse_linux:curl-debuginfo, p-cpe:/a:novell:suse_linux:curl-debugsource, p-cpe:/a:novell:suse_linux:libcurl4, p-cpe:/a:novell:suse_linux:libcurl4-debuginfo, cpe:/o:novell:suse_linux:12

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/10/23

Vulnerability Publication Date: 2017/10/06

Reference Information

CVE: CVE-2017-1000254, CVE-2017-1000257