MySQL 5.7.x < 5.7.20 Multiple Vulnerabilities (October 2017 CPU)

High Nessus Plugin ID 104050

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MySQL running on the remote host is 5.7.x prior to 5.7.20. It is, therefore, affected by multiple vulnerabilities as noted in the October 2017 Critical Patch Update advisory. Please consult the CVRF details for the applicable CVEs for additional information.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to MySQL version 5.7.20 or later.

See Also

https://dev.mysql.com/doc/relnotes/mysql/5.7/en/news-5-7-20.html

http://www.nessus.org/u?1e07fa0e

https://support.oracle.com/rs?type=doc&id=2307762.1

http://www.nessus.org/u?31acf95c

Plugin Details

Severity: High

ID: 104050

File Name: mysql_5_7_20.nasl

Version: 1.5

Type: remote

Family: Databases

Published: 2017/10/20

Modified: 2018/05/17

Dependencies: 91823, 10719

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.8

Temporal Score: 5.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:mysql

Required KB Items: Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/10/17

Vulnerability Publication Date: 2017/10/17

Reference Information

CVE: CVE-2017-10155, CVE-2017-10165, CVE-2017-10167, CVE-2017-10227, CVE-2017-10268, CVE-2017-10276, CVE-2017-10283, CVE-2017-10286, CVE-2017-10294, CVE-2017-10311, CVE-2017-10313, CVE-2017-10314, CVE-2017-10320, CVE-2017-10379, CVE-2017-10384, CVE-2018-2562, CVE-2018-2591

BID: 101314, 101337, 101390, 101397, 101402, 101406, 101410, 101415, 101420, 101424, 101433, 101441, 101444, 101446, 101448, 102713, 102714