Cisco IOS Software Plug-and-Play PKI API Certificate Validation Vulnerability

medium Nessus Plugin ID 103675

Synopsis

The remote device is missing a vendor-supplied security patch.

Description

According to its self-reported version, the IOS is affected by one or more vulnerabilities. Please see the included Cisco BIDs and the Cisco Security Advisory for more information.

Solution

Upgrade to the relevant fixed version referenced in Cisco bug ID(s) CSCvc33171..

See Also

http://www.nessus.org/u?5d9fc170

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCvc33171

Plugin Details

Severity: Medium

ID: 103675

File Name: cisco-sa-20170927-pnp-ios.nasl

Version: 1.17

Type: combined

Family: CISCO

Published: 10/6/2017

Updated: 4/12/2021

Risk Information

CVSS Score Source: CVE-2017-12228

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 5.9

Temporal Score: 5.2

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:cisco:ios

Required KB Items: Host/Cisco/IOS/Version

Exploit Ease: No known exploits are available

Patch Publication Date: 9/27/2017

Vulnerability Publication Date: 9/27/2017

Reference Information

CVE: CVE-2017-12228

BID: 101065

CISCO-BUG-ID: CSCvc33171

CISCO-SA: cisco-sa-20170927-pnp