Debian DSA-3982-1 : perl - security update

Medium Nessus Plugin ID 103392

Synopsis

The remote Debian host is missing a security-related update.

Description

Multiple vulnerabilities were discovered in the implementation of the Perl programming language. The Common Vulnerabilities and Exposures project identifies the following problems :

- CVE-2017-12837 Jakub Wilk reported a heap buffer overflow flaw in the regular expression compiler, allowing a remote attacker to cause a denial of service via a specially crafted regular expression with the case-insensitive modifier.

- CVE-2017-12883 Jakub Wilk reported a buffer over-read flaw in the regular expression parser, allowing a remote attacker to cause a denial of service or information leak.

Solution

Upgrade the perl packages.

For the oldstable distribution (jessie), these problems have been fixed in version 5.20.2-3+deb8u9.

For the stable distribution (stretch), these problems have been fixed in version 5.24.1-3+deb9u2.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=875596

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=875597

https://security-tracker.debian.org/tracker/CVE-2017-12837

https://security-tracker.debian.org/tracker/CVE-2017-12883

https://packages.debian.org/source/jessie/perl

https://packages.debian.org/source/stretch/perl

https://www.debian.org/security/2017/dsa-3982

Plugin Details

Severity: Medium

ID: 103392

File Name: debian_DSA-3982.nasl

Version: 3.4

Type: local

Agent: unix

Published: 2017/09/22

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:P

CVSS v3.0

Base Score: 9.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:perl, cpe:/o:debian:debian_linux:8.0, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2017/09/21

Reference Information

CVE: CVE-2017-12837, CVE-2017-12883

DSA: 3982