IBM DB2 9.7 < FP11 Special Build 36826 / 10.1 < FP6 Special Build 36827 / 10.5 < FP8 Special Build 36828 / < FP2 Special Build 36792 Multiple Vulnerabilities (UNIX)

High Nessus Plugin ID 103252


The remote database server is affected by multiple vulnerabilities.


According to its version, the installation of IBM DB2 running on the remote host is either 9.7 prior to fix pack 11 Special Build 36826, 10.1 prior to fix pack 6 Special Build 36827, 10.5 prior to fix pack 7 Special Build 36828, or prior to fix pack 2 Special Build 36792. It is, therefore, affected by multiple vulnerabilities related to privilege escalation as described in the advisories.

Note: swg22007183 only affects 10.5.x and, and swg22005740 only affects


Apply the appropriate IBM DB2 Special Build based on the most recent fix pack level for your branch.

See Also

Plugin Details

Severity: High

ID: 103252

File Name: db2_1112fp2_36792_nix.nasl

Version: $Revision: 1.3 $

Type: local

Family: Databases

Published: 2017/09/15

Modified: 2017/09/18

Dependencies: 86653

Risk Information

Risk Factor: High


Base Score: 7.2

Temporal Score: 5.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 6.7

Temporal Score: 5.8

Vector: CVSS:3.0/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:ibm:db2

Required KB Items: installed_sw/DB2 Server

Excluded KB Items: SMB/db2/Installed

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/09/07

Vulnerability Publication Date: 2016/09/07

Reference Information

CVE: CVE-2017-1434, CVE-2017-1438, CVE-2017-1439, CVE-2017-1420, CVE-2017-1452, CVE-2017-1519

OSVDB: 164932, 164933, 164934, 164935, 165136, 164937

IAVB: 2017-B-0123