FreeBSD : Django -- possible XSS in traceback section of technical 500 debug page (aaab03be-932d-11e7-92d8-4b26fc968492)

medium Nessus Plugin ID 102987

Language:

New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote FreeBSD host is missing one or more security-related updates.

Description

Django blog :

In older versions, HTML autoescaping was disabled in a portion of the template for the technical 500 debug page. Given the right circumstances, this allowed a cross-site scripting attack. This vulnerability shouldn't affect most production sites since you shouldn't run with DEBUG = True (which makes this page accessible) in your production settings.

Solution

Update the affected packages.

See Also

https://www.djangoproject.com/weblog/2017/sep/05/security-releases/

http://www.nessus.org/u?a9af21be

Plugin Details

Severity: Medium

ID: 102987

File Name: freebsd_pkg_aaab03be932d11e792d84b26fc968492.nasl

Version: 3.5

Type: local

Published: 9/7/2017

Updated: 1/4/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Low

Score: 3.8

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

CVSS v3

Risk Factor: Medium

Base Score: 6.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:py27-django110, p-cpe:/a:freebsd:freebsd:py27-django111, p-cpe:/a:freebsd:freebsd:py34-django110, p-cpe:/a:freebsd:freebsd:py34-django111, p-cpe:/a:freebsd:freebsd:py35-django110, p-cpe:/a:freebsd:freebsd:py35-django111, p-cpe:/a:freebsd:freebsd:py36-django110, p-cpe:/a:freebsd:freebsd:py36-django111, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 9/6/2017

Vulnerability Publication Date: 9/5/2017

Reference Information

CVE: CVE-2017-12794