openSUSE Security Update : expat (openSUSE-2017-993)

High Nessus Plugin ID 102946

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for expat fixes the following issues :

- CVE-2016-9063: Possible integer overflow to fix inside XML_Parse leading to unexpected behaviour (bsc#1047240)

- CVE-2017-9233: External Entity Vulnerability could lead to denial of service (bsc#1047236)

This update was imported from the SUSE:SLE-12:Update update project.

Solution

Update the affected expat packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1047236

https://bugzilla.opensuse.org/show_bug.cgi?id=1047240

Plugin Details

Severity: High

ID: 102946

File Name: openSUSE-2017-993.nasl

Version: 3.4

Type: local

Agent: unix

Published: 2017/09/05

Updated: 2018/09/04

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:expat, p-cpe:/a:novell:opensuse:expat-debuginfo, p-cpe:/a:novell:opensuse:expat-debuginfo-32bit, p-cpe:/a:novell:opensuse:expat-debugsource, p-cpe:/a:novell:opensuse:libexpat-devel, p-cpe:/a:novell:opensuse:libexpat-devel-32bit, p-cpe:/a:novell:opensuse:libexpat1, p-cpe:/a:novell:opensuse:libexpat1-32bit, p-cpe:/a:novell:opensuse:libexpat1-debuginfo, p-cpe:/a:novell:opensuse:libexpat1-debuginfo-32bit, cpe:/o:novell:opensuse:42.2, cpe:/o:novell:opensuse:42.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2017/09/04

Reference Information

CVE: CVE-2016-9063, CVE-2017-9233