Apache Struts 2.3.x Struts 1 plugin RCE (remote)

High Nessus Plugin ID 102918

Synopsis

The remote web server contains a web application that uses a Java framework which is affected by a remote code execution vulnerability.

Description

The Struts 1 plugin in Apache Struts 2.3.x is affected by a remote code execution vulnerability via a malicious field value passed in a raw message to the ActionMessage class.

Solution

Refer to the s2-048 vendor advisory for mitigation options

See Also

http://struts.apache.org/docs/s2-048.html

https://cwiki.apache.org/confluence/display/WW/S2-048

Plugin Details

Severity: High

ID: 102918

File Name: struts_2_3_x_rce.nasl

Version: 1.9

Type: remote

Family: CGI abuses

Published: 2017/09/01

Updated: 2019/11/12

Dependencies: 10107, 67257

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2017-9791

CVSS v2.0

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 9.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:struts

Exploit Available: true

Exploit Ease: Exploits are available

Exploited by Nessus: true

Vulnerability Publication Date: 2017/07/10

Exploitable With

Core Impact

Metasploit (Apache Struts 2 Struts 1 Plugin Showcase OGNL Code Execution)

Elliot (Apache Struts 2 Struts 1 Plugin ActionMessage < 2.3.32 RCE)

Reference Information

CVE: CVE-2017-9791

BID: 99484