FreeBSD : rubygems -- multiple vulnerabilities (3f6de636-8cdb-11e7-9c71-f0def1fd7ea2)

High Nessus Plugin ID 102833


The remote FreeBSD host is missing one or more security-related updates.


Official blog of RubyGems reports :

The following vulnerabilities have been reported: a DNS request hijacking vulnerability, an ANSI escape sequence vulnerability, a DoS vulnerability in the query command, and a vulnerability in the gem installer that allowed a malicious gem to overwrite arbitrary files.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 102833

File Name: freebsd_pkg_3f6de6368cdb11e79c71f0def1fd7ea2.nasl

Version: $Revision: 3.1 $

Type: local

Published: 2017/08/30

Modified: 2017/08/30

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:ruby22-gems, p-cpe:/a:freebsd:freebsd:ruby23-gems, p-cpe:/a:freebsd:freebsd:ruby24-gems, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2017/08/29

Vulnerability Publication Date: 2017/08/29