GLSA-201708-06 : GPL Ghostscript: Multiple vulnerabilities

Medium Nessus Plugin ID 102618

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201708-06 (GPL Ghostscript: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in GPL Ghostscript. Please review the CVE identifiers referenced below for additional information.
Impact :

A context-dependent attacker could entice a user to open a specially crafted PostScript file or PDF document using GPL Ghostscript possibly resulting in the execution of arbitrary code with the privileges of the process or a Denial of Service condition.
Workaround :

There is no known workaround at this time.

Solution

All GPL Ghostscript users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-text/ghostscript-gpl-9.21'

See Also

https://security.gentoo.org/glsa/201708-06

Plugin Details

Severity: Medium

ID: 102618

File Name: gentoo_GLSA-201708-06.nasl

Version: 3.3

Type: local

Published: 2017/08/21

Modified: 2018/10/01

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSSv3

Base Score: 7.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:ghostscript-gpl, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/08/21

Reference Information

CVE: CVE-2016-10219, CVE-2016-10220, CVE-2017-5951, CVE-2017-6196, CVE-2017-7207, CVE-2017-8291

GLSA: 201708-06