CVE-2016-10219

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The intersect function in base/gxfill.c in Artifex Software, Inc. Ghostscript 9.20 allows remote attackers to cause a denial of service (divide-by-zero error and application crash) via a crafted file.

References

http://www.debian.org/security/2017/dsa-3838

http://www.ghostscript.com/cgi-bin/findgit.cgi?4bef1a1d32e29b68855616020dbff574b9cda08f

https://bugs.ghostscript.com/show_bug.cgi?id=697453

https://security.gentoo.org/glsa/201708-06

Details

Source: MITRE

Published: 2017-04-03

Updated: 2017-11-04

Type: CWE-369

Risk Information

CVSS v2

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 5.5

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 1.8

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:artifex:ghostscript:9.20:*:*:*:*:*:*:*

Tenable Plugins

View all (17 total)

IDNameProductFamilySeverity
151342EulerOS Virtualization for ARM 64 3.0.2.0 : ghostscript (EulerOS-SA-2021-2089)NessusHuawei Local Security Checks
high
147428EulerOS Virtualization 3.0.2.6 : ghostscript (EulerOS-SA-2021-1434)NessusHuawei Local Security Checks
high
147424EulerOS Virtualization 3.0.6.6 : ghostscript (EulerOS-SA-2021-1476)NessusHuawei Local Security Checks
high
146154EulerOS 2.0 SP5 : ghostscript (EulerOS-SA-2021-1193)NessusHuawei Local Security Checks
high
132121EulerOS 2.0 SP3 : ghostscript (EulerOS-SA-2019-2586)NessusHuawei Local Security Checks
high
131862EulerOS 2.0 SP2 : ghostscript (EulerOS-SA-2019-2370)NessusHuawei Local Security Checks
high
109572SUSE SLES11 Security Update : ghostscript-library (SUSE-SU-2018:1140-1)NessusSuSE Local Security Checks
high
106745SUSE SLED12 / SLES12 Security Update : ghostscript (SUSE-SU-2018:0407-1)NessusSuSE Local Security Checks
high
106744openSUSE Security Update : ghostscript (openSUSE-2018-157)NessusSuSE Local Security Checks
high
102618GLSA-201708-06 : GPL Ghostscript: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high
101695Fedora 26 : ghostscript (2017-a606d224a5)NessusFedora Local Security Checks
high
100247Ubuntu 14.04 LTS / 16.04 LTS / 16.10 / 17.04 : ghostscript regression (USN-3272-2)NessusUbuntu Local Security Checks
high
100201Fedora 24 : ghostscript (2017-fae1506f94)NessusFedora Local Security Checks
high
100013Fedora 25 : ghostscript (2017-c85c0e5637)NessusFedora Local Security Checks
high
99741Debian DSA-3838-1 : ghostscript - security updateNessusDebian Local Security Checks
high
99726Ubuntu 12.04 LTS / 14.04 LTS / 16.04 LTS / 16.10 / 17.04 : ghostscript vulnerabilities (USN-3272-1)NessusUbuntu Local Security Checks
high
99544Debian DLA-905-1 : ghostscript security updateNessusDebian Local Security Checks
medium