openSUSE Security Update : fossil (openSUSE-2017-949)

Medium Nessus Plugin ID 102565


The remote openSUSE host is missing a security update.


This update for fossil to version 2.3 fixes the following issues :

- Potential XSS vulnerability on the /help webpage (boo#1053267)

This update also contains all upstream improvements and fixes in version 2.3 :

- Update internal Unicode character tables, used in regular expression handling, from version 9.0 to 10.0.

- Show the last-sync-URL on the /urllist page

- Added the 'Event Summary' activity report

- Added the 'Security Audit' page, available to administrators only

- Added the Last Login time to the user list page, for administrators only

- Added the --numstat option to the fossil diff command

- Limit the size of the heap and stack on unix systems, as a proactive defense against the Stack Clash attack

- Fix 'database locked' warnings caused by 'PRAGMA optimize'

- Documentation updates


Update the affected fossil packages.

See Also

Plugin Details

Severity: Medium

ID: 102565

File Name: openSUSE-2017-949.nasl

Version: $Revision: 3.1 $

Type: local

Agent: unix

Published: 2017/08/18

Modified: 2017/08/18

Dependencies: 12634

Risk Information

Risk Factor: Medium

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:fossil, p-cpe:/a:novell:opensuse:fossil-debuginfo, p-cpe:/a:novell:opensuse:fossil-debugsource, cpe:/o:novell:opensuse:42.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2017/08/16