FreeBSD : libsoup -- stack based buffer overflow (8e7bbddd-8338-11e7-867f-b499baebfeaf)

High Nessus Plugin ID 102553


The remote FreeBSD host is missing a security-related update.


Tobias Mueller reports :

libsoup is susceptible to a stack based buffer overflow attack when using chunked encoding. Regardless of libsoup being used as a server or client.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 102553

File Name: freebsd_pkg_8e7bbddd833811e7867fb499baebfeaf.nasl

Version: $Revision: 3.2 $

Type: local

Published: 2017/08/18

Modified: 2017/08/21

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:libsoup, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2017/08/17

Vulnerability Publication Date: 2017/08/17

Reference Information

CVE: CVE-2017-2885