PostgreSQL 9.2.x < 9.2.22 / 9.3.x < 9.3.18 / 9.4.x < 9.4.13 / 9.5.x < 9.5.8 / 9.6.x < 9.6.4 Multiple Vulnerabilities

High Nessus Plugin ID 102527


The remote database server is affected by multiple vulnerabilities.


The version of PostgreSQL installed on the remote host is 9.2.x prior to 9.2.22, 9.3.x prior to 9.3.18, 9.4.x prior to 9.4.13, 9.5.x prior to 9.5.8, or 9.6.x prior to 9.6.4. It is, therefore, affected by multiple vulnerabilities :

- An authentication bypass flaw exists in that an empty password is accepted in some authentication methods. (CVE-2017-7546)

- An information disclosure vulnerability exists in the 'pg_user_mappings' catalog view that can disclose passwords to users lacking server privileges. (CVE-2017-7547)

Note: The 'pg_user_mappings' update will only fix the behavior in newly created clusters utilizing initdb. To fix this issue on existing systems you will need to follow the steps in the release notes.

- A flaw exists in the lo_put() function due to improper checking of permissions that leads to ignoring of ACLs. (CVE-2017-7548)


Upgrade to PostgreSQL version 9.2.22 / 9.3.18 / 9.4.13 / 9.5.8 / 9.6.4 or later.

See Also

Plugin Details

Severity: High

ID: 102527

File Name: postgresql_20170810.nasl

Version: 1.13

Type: local

Family: Databases

Published: 2017/08/16

Updated: 2019/02/26

Dependencies: 63346

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2017-7546

CVSS v2.0

Base Score: 8.5

Temporal Score: 6.3

Vector: CVSS2#AV:N/AC:M/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:postgresql:postgresql

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/08/10

Vulnerability Publication Date: 2017/08/10

Reference Information

CVE: CVE-2017-7546, CVE-2017-7547, CVE-2017-7548