openSUSE Security Update : libsoup (openSUSE-2017-914)

High Nessus Plugin ID 102468


The remote openSUSE host is missing a security update.


This update for libsoup fixes the following issues :

- A bug in the HTTP Chunked Encoding code has been fixed that could have been exploited by attackers to cause a stack-based buffer overflow in client or server code running libsoup (bsc#1052916, CVE-2017-2885).

This update was imported from the SUSE:SLE-12-SP2:Update update project.


Update the affected libsoup packages.

See Also

Plugin Details

Severity: High

ID: 102468

File Name: openSUSE-2017-914.nasl

Version: $Revision: 3.1 $

Type: local

Agent: unix

Published: 2017/08/14

Modified: 2017/08/14

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libsoup-2_4-1, p-cpe:/a:novell:opensuse:libsoup-2_4-1-32bit, p-cpe:/a:novell:opensuse:libsoup-2_4-1-debuginfo, p-cpe:/a:novell:opensuse:libsoup-2_4-1-debuginfo-32bit, p-cpe:/a:novell:opensuse:libsoup-debugsource, p-cpe:/a:novell:opensuse:libsoup-devel, p-cpe:/a:novell:opensuse:libsoup-devel-32bit, p-cpe:/a:novell:opensuse:libsoup-lang, p-cpe:/a:novell:opensuse:typelib-1_0-Soup-2_4, cpe:/o:novell:opensuse:42.2, cpe:/o:novell:opensuse:42.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2017/08/11

Reference Information

CVE: CVE-2017-2885