openSUSE Security Update : cacti / cacti-spine (openSUSE-2017-889)

High Nessus Plugin ID 102249

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for cacti, cacti-spine fixes the following issues :

- CVE-2017-12065: Possible code execution via avgnan, outlier-start, or outlier-end parameter (bsc#1051633)

- CVE-2017-11691: XSS in auth_profile.php allows remote attackers to inject arbitrary JS via specially crafted HTTP Referer headers (bsc#1050950)

- CVE-2017-10970: XSS Issue in link.php bsc#1047512

- CVE-2017-11163: XSS Issue in lib/html_form.php bsc#1048102

In addition, cacti and cacti-spine were updated to the current stable release 1.1.16, containing all upstream improvements and bugfixes.

Solution

Update the affected cacti / cacti-spine packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1047512

https://bugzilla.opensuse.org/show_bug.cgi?id=1048102

https://bugzilla.opensuse.org/show_bug.cgi?id=1050950

https://bugzilla.opensuse.org/show_bug.cgi?id=1051633

Plugin Details

Severity: High

ID: 102249

File Name: openSUSE-2017-889.nasl

Version: $Revision: 1.2 $

Type: local

Agent: unix

Published: 2017/08/08

Modified: 2018/01/26

Dependencies: 12634

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSSv3

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:cacti, p-cpe:/a:novell:opensuse:cacti-spine, p-cpe:/a:novell:opensuse:cacti-spine-debuginfo, p-cpe:/a:novell:opensuse:cacti-spine-debugsource, cpe:/o:novell:opensuse:42.2, cpe:/o:novell:opensuse:42.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2017/08/07

Reference Information

CVE: CVE-2017-10970, CVE-2017-11163, CVE-2017-11691, CVE-2017-12065