SUSE SLED12 / SLES12 Security Update : libzypp, zypper (SUSE-SU-2017:2040-1)

Medium Nessus Plugin ID 102193


The remote SUSE host is missing one or more security updates.


The Software Update Stack was updated to receive fixes and enhancements. libzypp: Security issues fixed :

- CVE-2017-7435, CVE-2017-7436, CVE-2017-9269: Fix GPG check workflows, mainly for unsigned repositories and packages. (bsc#1045735, bsc#1038984) Bug fixes :

- Re-probe on refresh if the repository type changes.

- Propagate proper error code to DownloadProgressReport.

- Allow to trigger an appdata refresh unconditionally.

- Support custom repo variables defined in /etc/zypp/vars.d.

- Adapt loop mounting of ISO images. (bsc#1038132, bsc#1033236)

- Fix potential crash if repository has no baseurl.
(bsc#1043218) zypper :

- Adapt download callback to report and handle unsigned packages. (bsc#1038984)

- Report missing/optional files as 'not found' rather than 'error'. (bsc#1047785)

- Document support for custom repository variables defined in /etc/zypp/vars.d.

- Emphasize that it depends on how fast PackageKit will respond to a 'quit' request sent if PK blocks package management.

Note that Tenable Network Security has extracted the preceding description block directly from the SUSE security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product :

SUSE Linux Enterprise Software Development Kit 12-SP2:zypper in -t patch SUSE-SLE-SDK-12-SP2-2017-1252=1

SUSE Linux Enterprise Server for Raspberry Pi 12-SP2:zypper in -t patch SUSE-SLE-RPI-12-SP2-2017-1252=1

SUSE Linux Enterprise Server 12-SP2:zypper in -t patch SUSE-SLE-SERVER-12-SP2-2017-1252=1

SUSE Linux Enterprise Desktop 12-SP2:zypper in -t patch SUSE-SLE-DESKTOP-12-SP2-2017-1252=1

OpenStack Cloud Magnum Orchestration 7:zypper in -t patch SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2017-1252=1

To bring your system up-to-date, use 'zypper patch'.

See Also

Plugin Details

Severity: Medium

ID: 102193

File Name: suse_SU-2017-2040-1.nasl

Version: $Revision: 3.3 $

Type: local

Agent: unix

Published: 2017/08/04

Modified: 2017/08/16

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:U/RC:ND

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:libzypp, p-cpe:/a:novell:suse_linux:libzypp-debuginfo, p-cpe:/a:novell:suse_linux:libzypp-debugsource, p-cpe:/a:novell:suse_linux:zypper, p-cpe:/a:novell:suse_linux:zypper-debuginfo, p-cpe:/a:novell:suse_linux:zypper-debugsource, cpe:/o:novell:suse_linux:12

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/08/03

Reference Information

CVE: CVE-2017-7435, CVE-2017-7436, CVE-2017-9269

OSVDB: 162542, 162543, 162544