FreeBSD : Varnish -- Denial of service vulnerability (88a77ad8-77b1-11e7-b5af-a4badb2f4699)

High Nessus Plugin ID 102138


The remote FreeBSD host is missing one or more security-related updates.


phk reports :

A wrong if statement in the varnishd source code means that particular invalid requests from the client can trigger an assert.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 102138

File Name: freebsd_pkg_88a77ad877b111e7b5afa4badb2f4699.nasl

Version: $Revision: 3.1 $

Type: local

Published: 2017/08/03

Modified: 2017/08/03

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:varnish4, p-cpe:/a:freebsd:freebsd:varnish5, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2017/08/02

Vulnerability Publication Date: 2017/08/02