SSH Commands Require Privilege Escalation

info Nessus Plugin ID 102094
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

This plugin reports the SSH commands that failed with a response indicating that privilege escalation is required to run them.

Description

This plugin reports the SSH commands that failed with a response indicating that privilege escalation is required to run them. Either privilege escalation credentials were not provided, or the command failed to run with the provided privilege escalation credentials.

NOTE: Due to limitations inherent to the majority of SSH servers, this plugin may falsely report failures for commands containing error output expected by sudo, such as 'incorrect password', 'not in the sudoers file', or 'not allowed to execute'.

Plugin Details

Severity: Info

ID: 102094

File Name: ssh_commands_need_escalation.nasl

Version: 1.13

Type: local

Family: Settings

Published: 8/1/2017

Updated: 9/22/2020

Vulnerability Information

Reference Information

IAVB: 0001-B-0507