MySQL Cluster 7.3.x < 7.3.6 CLSTCONF RCE (July 2017 CPU)

High Nessus Plugin ID 101811


The remote database server is affected by a remote code execution vulnerability.


The version of MySQL Cluster running on the remote host is 7.3.x prior to 7.3.6. It is, therefore, affected by an overflow condition in the CLSTCONF component, specifically in the Python sock_recvfrom_into() function within file Modules/socketmodule.c, due to improper validation of user-supplied input when checking boundaries. An unauthenticated, remote attacker can exploit this, via a specially crafted string, to cause a denial of service condition or the execution of arbitrary code.


Upgrade to MySQL Cluster version 7.3.6 or later as referenced in the July 2017 Oracle Critical Patch Update advisory.

See Also

Plugin Details

Severity: High

ID: 101811

File Name: mysql_cluster_7_3_6.nasl

Version: $Revision: 1.4 $

Type: remote

Family: Databases

Published: 2017/07/19

Modified: 2017/10/19

Dependencies: 10719

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND


Base Score: 7.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Vulnerability Information

CPE: cpe:/a:oracle:mysql_cluster

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/07/11

Vulnerability Publication Date: 2014/01/14

Reference Information

CVE: CVE-2014-1912

BID: 65379

OSVDB: 102929

EDB-ID: 31875