Apache Struts 2.3.x < 2.3.33 / 2.5.x < 2.5.12 Multiple DoS

Medium Nessus Plugin ID 101548


A web application running on the remote host uses a Java framework that is affected by multiple denial of service vulnerabilities.


The version of Apache Struts running on the remote host is 2.3.x prior to 2.3.33, or 2.5.x prior to 2.5.12. It is, therefore, affected by multiple vulnerabilities :

- A denial of service vulnerability exists when handling a specially crafted URL in a form field when the built-in URL validator is used. An unauthenticated, remote attacker can exploit this to cause the server process to overload. Note that this issue only affects version 2.5.x. (CVE-2017-7672)

- A flaw exists in unspecified Spring AOP functionality that is used to secure Struts actions. An authenticated, remote attacker can exploit this to cause a denial of service condition. (CVE-2017-9787)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Apache Struts version 2.3.33 / 2.5.12 or later.
Alternatively, apply the workaround referenced in the vendor advisory.

See Also





Plugin Details

Severity: Medium

ID: 101548

File Name: struts_2_5_12.nasl

Version: $Revision: 1.5 $

Type: local

Family: Misc.

Published: 2017/07/14

Modified: 2017/09/08

Dependencies: 11936, 99671, 73943

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 6.5

Temporal Score: 5.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:struts

Required KB Items: Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/07/11

Vulnerability Publication Date: 2017/07/11

Reference Information

CVE: CVE-2017-7672, CVE-2017-9787

BID: 99562, 99563

OSVDB: 160703, 160704