Apache Struts 2.5.x < 2.5.12 Multiple DoS (S2-047) (S2-049)

critical Nessus Plugin ID 101548


A web application running on the remote host uses a Java framework that is affected by multiple denial of service vulnerabilities.


The version of Apache Struts running on the remote host is 2.5.x prior to 2.5.12. It is, therefore, affected by multiple vulnerabilities :

- A denial of service vulnerability exists when handling a specially crafted URL in a form field when the built-in URL validator is used. An unauthenticated, remote attacker can exploit this to cause the server process to overload. Note that this issue only affects version 2.5.x. (CVE-2017-7672)

- A flaw exists in unspecified Spring AOP functionality that is used to secure Struts actions. An authenticated, remote attacker can exploit this to cause a denial of service condition. (CVE-2017-9787)

- A deserialization vulnerability in Apache Commons FileUpload which could be leveraged for remote code execution. (CVE-2016-1000031)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Apache Struts version 2.5.12 or later.
Alternatively, apply the workaround referenced in the vendor advisory.

See Also






Plugin Details

Severity: Critical

ID: 101548

File Name: struts_2_5_12.nasl

Version: 1.17

Type: combined

Agent: windows, macosx, unix

Family: Misc.

Published: 7/14/2017

Updated: 12/5/2022

Configuration: Enable thorough checks

Supported Sensors: Frictionless Assessment Agent, Nessus Agent, Nessus

Risk Information


Risk Factor: Medium

Score: 6.7


Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS Score Source: CVE-2016-1000031


Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:struts

Exploit Ease: No known exploits are available

Patch Publication Date: 7/11/2017

Vulnerability Publication Date: 10/25/2016

Reference Information

CVE: CVE-2016-1000031, CVE-2017-7672, CVE-2017-9787

BID: 93604, 99562, 99563

IAVA: 2018-A-0355-S

TRA: TRA-2016-12