openSUSE Security Update : libmicrohttpd (openSUSE-2017-728)

Medium Nessus Plugin ID 101130


The remote openSUSE host is missing a security update.


This update for libmicrohttpd fixes the following issues :

- CVE-2013-7038: The MHD_http_unescape function in libmicrohttpd might have allowed remote attackers to obtain sensitive information or cause a denial of service (crash) via unspecified vectors that trigger an out-of-bounds read. (bsc#854443)

- CVE-2013-7039: Stack-based buffer overflow in the MHD_digest_auth_check function in libmicrohttpd, when MHD_OPTION_CONNECTION_MEMORY_LIMIT is set to a large value, allowed remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via a long URI in an authentication header. (bsc#854443)

- Fixed various bugs found during a 2017 audit, which are more hardening measures and not security issues.

This update was imported from the SUSE:SLE-12:Update update project.


Update the affected libmicrohttpd packages.

See Also

Plugin Details

Severity: Medium

ID: 101130

File Name: openSUSE-2017-728.nasl

Version: $Revision: 3.1 $

Type: local

Agent: unix

Published: 2017/06/30

Modified: 2017/06/30

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libmicrohttpd-debugsource, p-cpe:/a:novell:opensuse:libmicrohttpd-devel, p-cpe:/a:novell:opensuse:libmicrohttpd10, p-cpe:/a:novell:opensuse:libmicrohttpd10-debuginfo, p-cpe:/a:novell:opensuse:libmicrospdy-devel, p-cpe:/a:novell:opensuse:libmicrospdy0, p-cpe:/a:novell:opensuse:libmicrospdy0-debuginfo, p-cpe:/a:novell:opensuse:microspdy2http, p-cpe:/a:novell:opensuse:microspdy2http-debuginfo, cpe:/o:novell:opensuse:42.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2017/06/26

Reference Information

CVE: CVE-2013-7038, CVE-2013-7039