Check_MK < 1.4.0p6 XSS

Medium Nessus Plugin ID 101089


An IT monitoring application running on the remote host is affected by a cross-site scripting vulnerability.


The version of Check_MK running on the remote web server is prior to 1.4.0p6. It is, therefore, affected by a reflected cross-site (XSS) scripting vulnerability in due to error messages being interpreted as HTML when they should be plain text. An unauthenticated, remote attacker can exploit this to execute arbitrary script code in a user's browser session.


Upgrade to Check_MK version 1.4.0p6 or later.

See Also

Plugin Details

Severity: Medium

ID: 101089

File Name: check_mk_webapi_xss.nasl

Version: $Revision: 2.1 $

Type: remote

Published: 2017/06/28

Modified: 2017/06/28

Dependencies: 101090

Risk Information

Risk Factor: Medium


Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N


Base Score: 4.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N

Vulnerability Information

CPE: cpe:/a:check_mk_project:check_mk

Patch Publication Date: 2017/06/14

Vulnerability Publication Date: 2017/06/14

Reference Information

CVE: CVE-2017-9781