Fortinet FortiOS 5.2.x / 5.3.x / 5.4.x < 5.4.5 Multiple XSS (FG-IR-17-127)

Low Nessus Plugin ID 100998

Synopsis

The remote host is affected by multiple cross-site scripting vulnerabilities.

Description

The version of Fortinet FortiOS running on the remote device is 5.2.x, 5.3.x, or 5.4.x prior to 5.4.4. It is, therefore, affected by multiple cross-site scripting (XSS) vulnerabilities :

- A cross-site scripting (XSS) vulnerability exists when saving configuration revisions due to improper validation of user-supplied input to comments before returning it to users. An authenticated, remote attacker can exploit this, via a specially crafted request, to execute arbitrary script code in a user's browser session. (CVE-2017-7734)

- A cross-site scripting (XSS) vulnerability exists when creating or editing user groups due to improper validation of user-supplied input to groups before returning it to users. An authenticated, remote attacker can exploit this, via a specially crafted request, to execute arbitrary script code in a user's browser session. (CVE-2017-7735)

Solution

Upgrade to Fortinet FortiOS version 5.4.5 or later.

See Also

http://fortiguard.com/psirt/FG-IR-17-127

Plugin Details

Severity: Low

ID: 100998

File Name: fortios_FG-IR-17-127.nasl

Version: 1.5

Type: local

Family: Firewalls

Published: 2017/06/23

Modified: 2018/07/12

Dependencies: 73522

Risk Information

Risk Factor: Low

CVSSv2

Base Score: 3.5

Temporal Score: 2.6

Vector: CVSS2#AV:N/AC:M/Au:S/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 4.1

Temporal Score: 3.6

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:fortinet:fortios

Required KB Items: Host/Fortigate/model, Host/Fortigate/version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/06/15

Vulnerability Publication Date: 2017/06/15

Reference Information

CVE: CVE-2017-7734, CVE-2017-7735

BID: 99098