openSUSE Security Update : mercurial (openSUSE-2017-689)

High Nessus Plugin ID 100830


The remote openSUSE host is missing a security update.


This update for mercurial fixes the following issues :

- CVE-2017-9462: Fix the arbitrary code exec by remote users via 'hg serve --stdio' (boo#1043063)


Update the affected mercurial packages.

See Also

Plugin Details

Severity: High

ID: 100830

File Name: openSUSE-2017-689.nasl

Version: $Revision: 3.2 $

Type: local

Agent: unix

Published: 2017/06/16

Modified: 2018/01/26

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C


Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:mercurial, p-cpe:/a:novell:opensuse:mercurial-debuginfo, p-cpe:/a:novell:opensuse:mercurial-debugsource, p-cpe:/a:novell:opensuse:mercurial-lang, cpe:/o:novell:opensuse:42.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2017/06/15

Reference Information

CVE: CVE-2017-9462