GLSA-201706-14 : FreeType: Multiple vulnerabilities

critical Nessus Plugin ID 100657

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201706-14 (FreeType: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in FreeType. Please review the CVE identifiers referenced below for details.
Impact :

A remote attacker could entice a user to use a specially crafted font file using FreeType, possibly resulting in execution of arbitrary code with the privileges of the process or a Denial of Service condition.
Workaround :

There is no known workaround at this time.

Solution

All FreeType users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=media-libs/freetype-2.8'

See Also

https://security.gentoo.org/glsa/201706-14

Plugin Details

Severity: Critical

ID: 100657

File Name: gentoo_GLSA-201706-14.nasl

Version: 3.3

Type: local

Published: 6/7/2017

Updated: 1/11/2021

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:freetype, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 6/6/2017

Reference Information

CVE: CVE-2016-10244, CVE-2016-10328, CVE-2017-7857, CVE-2017-7858, CVE-2017-7864, CVE-2017-8105, CVE-2017-8287

GLSA: 201706-14