CVE-2017-8287

critical
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

FreeType 2 before 2017-03-26 has an out-of-bounds write caused by a heap-based buffer overflow related to the t1_builder_close_contour function in psaux/psobjs.c.

References

http://git.savannah.gnu.org/cgit/freetype/freetype2.git/commit/?id=3774fc08b502c3e685afca098b6e8a195aded6a0

http://www.debian.org/security/2017/dsa-3839

http://www.securityfocus.com/bid/99091

https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=941

https://security.gentoo.org/glsa/201706-14

https://www.oracle.com/security-alerts/cpuapr2020.html

https://www.oracle.com/technetwork/security-advisory/cpuapr2019-5072813.html

Details

Source: MITRE

Published: 2017-04-27

Updated: 2021-01-26

Type: CWE-119

Risk Information

CVSS v2

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

CVSS v3

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:freetype:freetype:*:*:*:*:*:*:*:* versions up to 2.7.1 (inclusive)

Tenable Plugins

View all (19 total)

IDNameProductFamilySeverity
140973EulerOS Virtualization for ARM 64 3.0.6.0 : freetype (EulerOS-SA-2020-2025)NessusHuawei Local Security Checks
critical
121695Photon OS 1.0: Freetype2 PHSA-2017-0017NessusPhotonOS Local Security Checks
critical
119072EulerOS Virtualization 2.5.1 : freetype (EulerOS-SA-2018-1381)NessusHuawei Local Security Checks
critical
111866Photon OS 1.0: Freetype2 / Libtirpc / Rpcbind PHSA-2017-0017 (deprecated)NessusPhotonOS Local Security Checks
high
106896SUSE SLES11 Security Update : freetype2 (SUSE-SU-2018:0462-1)NessusSuSE Local Security Checks
critical
106747SUSE SLED12 / SLES12 Security Update : freetype2 (SUSE-SU-2018:0414-1)NessusSuSE Local Security Checks
critical
106743openSUSE Security Update : freetype2 (openSUSE-2018-156)NessusSuSE Local Security Checks
critical
101848EulerOS 2.0 SP1 : freetype (EulerOS-SA-2017-1114)NessusHuawei Local Security Checks
critical
101655Fedora 26 : freetype (2017-71b9a2ef5f)NessusFedora Local Security Checks
critical
100813EulerOS 2.0 SP2 : freetype (EulerOS-SA-2017-1110)NessusHuawei Local Security Checks
critical
100657GLSA-201706-14 : FreeType: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
100283FreeBSD : freetype2 -- buffer overflows (4a088d67-3af2-11e7-9d75-c86000169601)NessusFreeBSD Local Security Checks
critical
100265Ubuntu 12.04 LTS : FreeType vulnerabilities (USN-3282-2)NessusUbuntu Local Security Checks
high
100223Slackware 13.0 / 13.1 / 13.37 / 14.0 / 14.1 / 14.2 / current : freetype (SSA:2017-136-01)NessusSlackware Local Security Checks
critical
100101Ubuntu 14.04 LTS / 16.04 LTS / 16.10 / 17.04 : freetype vulnerabilities (USN-3282-1)NessusUbuntu Local Security Checks
critical
99997Debian DLA-931-1 : freetype security updateNessusDebian Local Security Checks
critical
100011Fedora 24 : freetype (2017-950cc68400)NessusFedora Local Security Checks
critical
100009Fedora 25 : freetype (2017-5760b80676)NessusFedora Local Security Checks
critical
99742Debian DSA-3839-1 : freetype - security updateNessusDebian Local Security Checks
critical