Squid 3.5.x < 3.5.23 / 4.x < 4.0.17 Multiple Vulnerabilities

Medium Nessus Plugin ID 100617

Synopsis

The remote proxy server is affected by multiple vulnerabilities.

Description

According to its banner, the version of Squid running on the remote host is 3.5.x prior to 3.5.23 or 4.x prior to 4.0.17. It is, therefore, affected by multiple vulnerabilities :

- A flaw exists in client_side_reply.cc due to incorrect HTTP conditional request handling. An unauthenticated, remote attacker can exploit this to disclose sensitive information regarding the browser sessions of other clients. (CVE-2016-10002)

- A flaw exists in client_side_reply.cc due to improper HTTP request header comparison, which results in the Collapsed Forwarding feature incorrectly identifying some private responses as being suitable for delivery to multiple clients. An unauthenticated, remote attacker can exploit this to disclose sensitive information regarding the browser sessions of other clients. Note that this issue only affects Squid if it is configured to use the Collapsed Forwarding feature.
(CVE-2016-10003)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.
Furthermore, the patch released to address these vulnerabilities does not cause the version given in the banner to be updated. If the patch has been applied properly and the service has been restarted, then consider this to be a false positive.

Solution

Upgrade to Squid version 3.5.23 / 4.0.17 or later. Alternatively, apply the vendor-supplied patch.

See Also

http://www.squid-cache.org/Advisories/

http://www.squid-cache.org/Advisories/SQUID-2016_10.txt

http://www.squid-cache.org/Advisories/SQUID-2016_11.txt

Plugin Details

Severity: Medium

ID: 100617

File Name: squid_4_0_17.nasl

Version: $Revision: 1.2 $

Type: remote

Family: Firewalls

Published: 2017/06/05

Modified: 2017/06/07

Dependencies: 49692

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Vulnerability Information

CPE: cpe:/a:squid-cache:squid

Required KB Items: www/squid, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/12/16

Vulnerability Publication Date: 2016/12/16

Reference Information

CVE: CVE-2016-10002, CVE-2016-10003

BID: 94953