Squid 3.5.x < 3.5.23 / 4.x < 4.0.17 Information Disclosure Vulnerability (SQUID-2016:10)

high Nessus Plugin ID 100617


The remote proxy server is affected by an information disclosure vulnerability.


According to its banner, the version of Squid running on the remote host is 3.x prior to 3.5.23, or 4.x prior to 4.0.17. It is, therefore, affected by an information disclosure vulnerability in the collapsed forwarding feature due to the incorrect comparison of request headers. An unauthenticated, remote attacker can exploit this to disclose potentially sensitive information.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to Squid version 3.5.23 or 4.0.17 or later. Alternatively, apply the vendor-supplied patch.

See Also


Plugin Details

Severity: High

ID: 100617

File Name: squid_4_0_17.nasl

Version: 1.6

Type: remote

Family: Firewalls

Published: 6/5/2017

Updated: 3/27/2019

Configuration: Enable paranoid mode

Supported Sensors: Nessus

Risk Information


Risk Factor: Low

Score: 3.6


Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

CVSS Score Source: CVE-2016-10003


Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:squid-cache:squid

Required KB Items: Settings/ParanoidReport, installed_sw/Squid

Exploit Ease: No known exploits are available

Patch Publication Date: 5/6/2016

Vulnerability Publication Date: 5/6/2016

Reference Information

CVE: CVE-2016-10003

BID: 94953