Fortinet FortiOS 5.0.x / 5.2.x < 5.2.11 'global-label' Parameter XSS (FG-IR-17-057)

Low Nessus Plugin ID 100384


The remote host is affected by a cross-site scripting vulnerability.


The version of Fortinet FortiOS running on the remote device is 5.0.x or 5.2.x prior to 5.2.11. It is, therefore, affected by a stored cross-site scripting (XSS) vulnerability due to improper validation of user-supplied input to the 'global-label' parameter. An authenticated, remote attacker can exploit this, via a specially crafted request, to execute arbitrary script code in a user's browser session.


Upgrade to Fortinet FortiOS version 5.2.11 or later.

See Also

Plugin Details

Severity: Low

ID: 100384

File Name: fortios_FG-IR-17-057.nasl

Version: $Revision: 1.5 $

Type: local

Family: Firewalls

Published: 2017/05/24

Modified: 2017/08/14

Dependencies: 73522

Risk Information

Risk Factor: Low


Base Score: 3.5

Temporal Score: 2.9

Vector: CVSS2#AV:N/AC:M/Au:S/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND


Base Score: 5

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:N

Vulnerability Information

CPE: cpe:/o:fortinet:fortios

Required KB Items: Host/Fortigate/model, Host/Fortigate/version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/05/17

Vulnerability Publication Date: 2017/05/17

Reference Information

CVE: CVE-2017-3128

BID: 98514

OSVDB: 157745