openSUSE Security Update : swftools (openSUSE-2017-564)

Medium Nessus Plugin ID 100114


The remote openSUSE host is missing a security update.


This update for swftools fixes the following issues :

- CVE-2017-8400: out-of-bound write of heap data issue (bsc#1037050)

- CVE-2017-8401: out-of-bound read of heap data issue (bsc#1037051)


Update the affected swftools packages.

See Also

Plugin Details

Severity: Medium

ID: 100114

File Name: openSUSE-2017-564.nasl

Version: $Revision: 3.3 $

Type: local

Agent: unix

Published: 2017/05/11

Modified: 2018/01/26

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P


Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:swftools, p-cpe:/a:novell:opensuse:swftools-debuginfo, p-cpe:/a:novell:opensuse:swftools-debugsource, cpe:/o:novell:opensuse:42.1, cpe:/o:novell:opensuse:42.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2017/05/10

Reference Information

CVE: CVE-2017-8400, CVE-2017-8401