FreeBSD : kauth: Local privilege escalation (0baee383-356c-11e7-b9a9-50e549ebab6c)

High Nessus Plugin ID 100113

Synopsis

The remote FreeBSD host is missing one or more security-related updates.

Description

Albert Astals Cid reports :

KAuth contains a logic flaw in which the service invoking dbus is not properly checked. This allows spoofing the identity of the caller and with some carefully crafted calls can lead to gaining root from an unprivileged account.

Solution

Update the affected packages.

See Also

https://www.openwall.com/lists/oss-security/2017/05/10/3

https://www.kde.org/info/security/advisory-20170510-1.txt

http://www.nessus.org/u?5d7e1b89

Plugin Details

Severity: High

ID: 100113

File Name: freebsd_pkg_0baee383356c11e7b9a950e549ebab6c.nasl

Version: 3.6

Type: local

Published: 2017/05/11

Updated: 2019/04/10

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.2

Temporal Score: 5.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 7.8

Temporal Score: 7

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:kdelibs, p-cpe:/a:freebsd:freebsd:kf5-kauth, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/05/10

Vulnerability Publication Date: 2017/05/10

Reference Information

CVE: CVE-2017-8422