MySQL Server 5.5.x <= 5.5.27 / 5.1.x <= 5.1.65 Multiple Unspecified Vulnerabilities

Medium Log Correlation Engine Plugin ID 801117

Synopsis

The remote database server is vulnerable to multiple attack vectors.

Description

The version of MySQL 5.5 / 5.1 installed on the remote host is earlier than 5.5.28 / 5.1.66. As such, it is reportedly affected by the following vulnerabilities:

- An exploitable vulnerability requiring logon to the Operating System which can result in unauthorized read access to a subset of MySQL Server accessible data. (CVE-2012-3160)

- An exploitable vulnerability which allows successful authenticated network attacks via multiple protocols. A successful attack of this vulnerability can result in a Denial-of-Service. (CVE-2012-3177, CVE 2012-3180)

Solution

Upgrade to MySQL Community Server 5.5.28 / 5.1.66 later.

See Also

http://www.oracle.com/technetwork/topics/security/cpuoct2012-1515893.html

http://www.oracle.com/technetwork/topics/security/cpuoct2012verbose-1515934.html

Plugin Details

Severity: Medium

ID: 801117

File Name: 801117.prm

Family: Database

Published: 2012/10/19

Nessus ID: 62639, 62642

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 2012/10/16

Vulnerability Publication Date: 2012/10/16

Reference Information

CVE: CVE-2012-3160, CVE-2012-3177, CVE-2012-3180

BID: 56003, 56005, 56027