PHP < 5.3.9 Multiple Vulnerabilities

high Log Correlation Engine Plugin ID 801116
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server uses a version of PHP that is affected by multiple vulnerabilities.

Description

Versions of PHP earlier than 5.3.9 are potentially affected by multiple vulnerabilities :

- It is possible to create a denial of service condition by sending multiple, specially crafted requests containing parameter values that cause hash collisions when computing the hash values for storage in a hash table. (CVE-2011-4885)

- An integer overflow exists in the exif_process_IFD_TAG function in exif.c that can allow a remote attacker to read arbitrary memory locations or cause a denial of service condition. This vulnerability only affects PHP 5.4.0beta2 on 32-bit platforms. (CVE-2011-4566)

- Calls to libxslt are not restricted via xsltSetSecurityPrefs(), which could allow an attacker to create or overwrite file, resulting in arbitrary code execution. (CVE-2012-0057)

- An error exists in the function 'tidy_diagnose' that can allow an attacker to cause the application to dereference a null pointer. This causes the application to crash. (CVE-2012-0781)

- The 'PDORow' implementation contains an error that can cause application crashes when interacting with the session feature. C(VE-2012-0788)

- An error exists in the timezone handling such that repeated calls to the function 'strtotime' can allow a denial of service attack via memory consuption. (CVE-2012-0789)

Solution

Upgrade to PHP version 5.3.9 or later.

See Also

http://.php.net/releases/5.3.9.php

http://.php.net/ChangeLog-5.php#5.3.9

xhe.myxwiki.org/xwiki/bin/view/XSLT/Application_PHP5

http://.php.net/archive/2012.php#id2012-01-11-1

archives.neohapsis.com/archives/bugtraq/2012-01/0092.html

Plugin Details

Severity: High

ID: 801116

Family: Web Servers

Published: 1/16/2012

Updated: 1/16/2012

Nessus ID: 57537

Risk Information

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 1/11/2012

Vulnerability Publication Date: 11/29/2011

Reference Information

CVE: CVE-2011-4566, CVE-2011-4885, CVE-2012-0057, CVE-2012-0781, CVE-2012-0789, CVE-2012-0788

BID: 50907, 51193, 51992, 51806, 51952, 52043