CVE-2012-0781

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The tidy_diagnose function in PHP 5.3.8 might allow remote attackers to cause a denial of service (NULL pointer dereference and application crash) via crafted input to an application that attempts to perform Tidy::diagnose operations on invalid objects, a different vulnerability than CVE-2011-4153.

References

http://archives.neohapsis.com/archives/bugtraq/2012-01/0092.html

http://cxsecurity.com/research/103

http://lists.opensuse.org/opensuse-security-announce/2012-03/msg00013.html

http://lists.opensuse.org/opensuse-security-announce/2012-03/msg00016.html

http://secunia.com/advisories/48668

http://www.exploit-db.com/exploits/18370/

Details

Source: MITRE

Published: 2012-01-18

Updated: 2018-01-09

Type: CWE-399

Risk Information

CVSS v2

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:php:php:5.3.8:*:*:*:*:*:*:*

Tenable Plugins

View all (12 total)

IDNameProductFamilySeverity
74580openSUSE Security Update : php5 (openSUSE-SU-2012:0426-1)NessusSuSE Local Security Checks
high
68570Oracle Linux 6 : php (ELSA-2012-1046)NessusOracle Linux Local Security Checks
high
61358Scientific Linux Security Update : php on SL6.x i386/x86_64 (20120627)NessusScientific Linux Local Security Checks
high
59938CentOS 6 : php (CESA-2012:1046)NessusCentOS Local Security Checks
high
59752RHEL 6 : php (RHSA-2012:1046)NessusRed Hat Local Security Checks
high
59603Ubuntu 8.04 LTS / 10.04 LTS / 11.04 / 11.10 / 12.04 LTS : php5 vulnerabilities (USN-1481-1)NessusUbuntu Local Security Checks
high
58740SuSE 11.1 Security Update : PHP5 (SAT Patch Number 5964)NessusSuSE Local Security Checks
high
58480SuSE 10 Security Update : PHP5 (ZYPP Patch Number 8009)NessusSuSE Local Security Checks
high
57925Debian DSA-2408-1 : php5 - several vulnerabilitiesNessusDebian Local Security Checks
high
801116PHP < 5.3.9 Multiple VulnerabilitiesLog Correlation EngineWeb Servers
high
6263PHP < 5.3.9 Multiple VulnerabilitiesNessus Network MonitorWeb Servers
high
57537PHP < 5.3.9 Multiple VulnerabilitiesNessusCGI abuses
high