PHP < 5.3.2 / 5.2.13 Multiple Vulnerabilities

Medium Log Correlation Engine Plugin ID 801102


The remote web server uses a version of PHP that is affected by multiple vulnerabilities.


According to its banner, the version of PHP installed on the remote host is earlier than 5.3.2 / 5.2.13. Such versions are potentially affected by multiple vulnerabilities :

- A safe_mode validation issue inside 'tempnam()' when the directory path does not end with a '/'.

- A possible open_basedir/safe_mode bypass in the session extension.


Upgrade to PHP version 5.3.2 / 5.2.13 or later.

See Also

Plugin Details

Severity: Medium

ID: 801102

Family: Web Servers

Published: 2010/02/26

Nessus ID: 44921

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 2010/02/25

Vulnerability Publication Date: 2010/02/26

Reference Information

CVE: CVE-2010-1128, CVE-2010-1129

BID: 38430, 38431, 38182