PHP 5.2.x < 5.2.12 Multiple Vulnerabilities

Medium Log Correlation Engine Plugin ID 801091


The remote web server uses a version of PHP that is vulnerable to multiple attack vectors.


According to its banner, the version of PHP 5.2.x installed on the remote host is earlier than 5.2.12. Such versions are potentially affected by multiple vulnerabilities :

- A safe_mode bypass in tempnam(). (CVE-2009-3557)

- An open_basedir bypass in posix_mkfifo(). (CVE-2009-3558)

- A possible denial-of-service via temporary file exhaustion caused by a failure to limit the number of file uploads per request. (CVE-2009-4017)

- An arbitrary code execution vulnerability in the 'session.save_path()' function and the '$_SESSION' data structure. (CVE-2009-4143)

- A cross-site scripting vulnerability becuase the 'htmlspecialcharacters()' function fails to properly handle some malformed multibyte character sequences.


Upgrade to PHP version 5.2.12 or later.

See Also

Plugin Details

Severity: Medium

ID: 801091

Family: Web Servers

Published: 2009/12/18

Nessus ID: 43351

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5.8

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 2009/12/17

Vulnerability Publication Date: 2009/12/17

Reference Information

CVE: CVE-2009-3557, CVE-2009-3558, CVE-2009-4017, CVE-2009-4142, CVE-2009-4143

BID: 37389, 37390