PHP < 5.2.8 magic_quotes_gpc Security Bypass

High Log Correlation Engine Plugin ID 801078


The remote web server uses a version of PHP that is affected by a security bypass weakness.


According to its banner, the version of PHP installed on the remote host is 5.2.7. This version introduced a regression with regard to 'magic_quotes' functionality due to an incorrect fix to the filter extension. As a result, the 'magic_quotes_gpc' setting remains off even if it is set to on.


Upgrade to version 5.2.8 or higher.

See Also

Plugin Details

Severity: High

ID: 801078

File Name: 801078.prm

Family: Web Servers

Nessus ID: 35067

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Reference Information

CVE: CVE-2008-5844

BID: 32673