PHP < 5.2.6 Multiple Vulnerabilities

High Log Correlation Engine Plugin ID 801068

Synopsis

The remote web server uses a version of PHP that is affected by multiple flaws.

Description

The version of PHP installed on the remote host is older than 5.2.6. Such versions may be affected by the following issues :

- A stack buffer overflow in FastCGI SAPI.
- An integer overflow in printf().
- An unspecified security issue tracked by CVE-2008-0599.
- A safe_mode bypass in cURL.
- Incomplete handling of multibyte chars inside escapeshellcmd().
- Issues in the bundled PCRE fixed by version 7.6.

Solution

Upgrade to version 5.2.6 or higher.

See Also

archives.neohapsis.com/archives/bugtraq/2008-03/0321.html

archives.neohapsis.com/archives/fulldisclosure/2008-05/0103.html

archives.neohapsis.com/archives/fulldisclosure/2008-05/0107.html

http://.php.net/releases/5_2_6.php

Plugin Details

Severity: High

ID: 801068

File Name: 801068.prm

Family: Web Servers

Nessus ID: 32123

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Reference Information

CVE: CVE-2007-4850, CVE-2008-0674, CVE-2008-2050, CVE-2008-2051, CVE-2008-0599

BID: 29009