Google Chrome < 19.0.1084.52 Multiple Vulnerabilities

High Log Correlation Engine Plugin ID 800897


The remote host contains a web browser that is affected by multiple vulnerabilities.


Versions of Google Chrome earlier than 19.0.1084.52 are potentially affected by the following vulnerabilities :

- An error exists in the v8 JavaScript engine that can cause application crashes during garbage collection. (CVE-2011-3103)

- An out-of-bounds read error exists related to 'Skia'. (CVE-2011-3104)

- Use-after-free errors exists related to 'first-letter handling', browser cache, and invalid encrypted PDFs. (CVE-2011-3105, CVE-2011-3108, CVE-2011-3112)

- A memory corruption error exists related to websockets and SSL. (CVE-2011-3106)

- An error exists related to plugin-in JavaScript bindings that can cause the application to crash. (CVE-2011-3107)

- An out-of-bounds write error exists related to PDF processing. (CVE-2011-3110)

- An invalid read error exists related to the v8 Java Script engine. (CVE-2011-3111)

- An invalid cast error exists related to colorspace handling in PDF processing. (CVE-2011-3113)

- A buffer overflow error exists related to PDF functions. (CVE-2011-3114)

- A type corruption error exists related to the v8 JavaScript engine. (CVE-2011-3115)


Upgrade to Google Chrome 19.0.1084.52 or later.

See Also

Plugin Details

Severity: High

ID: 800897

Family: Web Clients

Published: 2012/05/24

Nessus ID: 59255

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 2012/05/23

Vulnerability Publication Date: 2012/05/23

Reference Information

CVE: CVE-2011-3103, CVE-2011-3104, CVE-2011-3105, CVE-2011-3106, CVE-2011-3107, CVE-2011-3108, CVE-2011-3110, CVE-2011-3111, CVE-2011-3112, CVE-2011-3113, CVE-2011-3114, CVE-2011-3115

BID: 53679