Apache Tomcat 7.0.x < 7.0.40 Information Disclosure

medium Log Correlation Engine Plugin ID 800784
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server is affected by an information disclosure vulnerability

Description

Versions of Tomcat 7.0.x earlier than 7.0.40 are potentially affected by an error related to 'AsyncListeners' that throw 'RuntimeExecptions' that could allow elements of certain requests to be disclosed in response to other requests

Solution

Upgrade to Apache Tomcat 7.0.40 or later.

See Also

http://tomcat.apache.org/security-7.html#Fixed_in_Apache_Tomcat_7.0.40

Plugin Details

Severity: Medium

ID: 800784

Family: Web Servers

Published: 5/20/2013

Updated: 5/20/2013

Nessus ID: 66428

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 5/9/2013

Vulnerability Publication Date: 5/10/2013

Reference Information

CVE: CVE-2013-2071

BID: 59798